1С 8.3 БСП ДобавитьФайлы - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП ДобавитьФайлы

Данные > Примеры кода 1С > 1С 8.3 БСП > Файлы (в работе)
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП ДобавитьФайлы. Открывает диалог выбора файлов для помещения в программу одного или нескольких файлов.
Примера кода от rayastar
РаботаСФайламиКлиент.ДобавитьФайлы(ВладелецФайла, ИдентификаторФормы, Фильтр, ГруппаФайлов, ОбработчикРезультата);

//
&НаКлиенте
Процедура ДобавитьФайл()

   ТекущиеДанные = Элементы.Список.ТекущиеДанные;
   ГруппаФайлов = Неопределено;
   Если ТекущиеДанные <> Неопределено И ТекущиеДанные.ЭтоГруппа И ТекущиеДанные.ВладелецФайла = Параметры.ВладелецФайла Тогда
       ГруппаФайлов = ТекущиеДанные.Ссылка;
   КонецЕсли;
   Если ЭтоВладелецЭлементовСправочникаФайлы Тогда
       РаботаСФайламиСлужебныйКлиент.ДобавитьФайлИзФайловойСистемы(Параметры.ВладелецФайла, ЭтотОбъект);
   Иначе
       // РаботаСФайламиКлиент.ДобавитьФайлы
       РаботаСФайламиКлиент.ДобавитьФайлы(Параметры.ВладелецФайла, УникальныйИдентификатор, , ГруппаФайлов);
   КонецЕсли;

КонецПроцедуры
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 22.08.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому