1С 8.3 БСП ХранилищеНастроекДанныхФормЗагрузить - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП ХранилищеНастроекДанныхФормЗагрузить

Данные > Примеры кода 1С > 1С 8.3 БСП > Хранилище настроек
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП ХранилищеНастроекДанныхФормЗагрузить. Загружает настройку из хранилища настроек данных форм.
Примера кода от rayastar
Результат = ОбщегоНазначения.ХранилищеНастроекДанныхФормЗагрузить(КлючОбъекта, КлючНастроек, ЗначениеПоУмолчанию, ОписаниеНастроек, ИмяПользователя);

//
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

   УсловноеОформление.Элементы.Очистить();
   РаботаСФайламиСлужебный.ЗаполнитьУсловноеОформлениеСпискаФайлов(Список);
   РаботаСФайламиСлужебный.ЗаполнитьУсловноеОформлениеСпискаПапок(Папки);
   РаботаСФайламиСлужебный.ДобавитьОтборыВСписокФайлов(Список);

   Элементы.ПоказыватьСлужебныеФайлы.Видимость = Пользователи.ЭтоПолноправныйПользователь();

   Если Параметры.Свойство("Папка") И Параметры.Папка <> Неопределено Тогда
       ПапкаПриОткрытии = Параметры.Папка;
   Иначе
       ПапкаПриОткрытии = ОбщегоНазначения.ХранилищеНастроекДанныхФормЗагрузить("Файлы", "ТекущаяПапка");
       Если ПапкаПриОткрытии = Неопределено Тогда // Попытка загрузки настроек, сохраненных в предыдущих версиях.
           ПапкаПриОткрытии = ОбщегоНазначения.ХранилищеНастроекДанныхФормЗагрузить("ХранилищеФайлов", "ТекущаяПапка");
       КонецЕсли;
   КонецЕсли;

КонецПроцедуры
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 22.08.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому