1С 8.3 БСП ХранилищеОбщихНастроекЗагрузить - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП ХранилищеОбщихНастроекЗагрузить

Данные > Примеры кода 1С > 1С 8.3 БСП > Хранилище настроек
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП ХранилищеОбщихНастроекЗагрузить. Загружает настройку из хранилища общих настроек.
Примера кода от rayastar
Результат = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить(КлючОбъекта, КлючНастроек, ЗначениеПоУмолчанию, ОписаниеНастроек, ИмяПользователя);


//
&НаСервере
Процедура ВосстановитьНастройкиФормы()
  Ответственный = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ПанельОбменСВЕТИС", "Ответственный",    Ответственный);
КонецПроцедуры

// ОбщегоНазначенияВызовСервера.ХранилищеОбщихНастроекЗагрузить
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Пример как сохранить/восстановить настройки табличной части
&НаСервере
Процедура СохранитьЗначения()

   Ключ = "МатериальныйОтчет";
   Настройки = Новый Соответствие;
   Настройки.Вставить("ТЧМатериалы", Объект.Материалы.Выгрузить());
   Настройки.Вставить("ТЧПоставщики", Объект.Поставщики.Выгрузить());
   ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ОтчетПоМатериалам", Ключ, Настройки);

КонецПроцедуры

&НаСервере
Процедура ВосстановитьЗначения()

   Ключ = "МатериальныйОтчет";
   Настройки = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ОтчетПоМатериалам", Ключ);
   Если ТипЗнч(Настройки) = Тип("Соответствие") Тогда
       Объект.Материалы.Загрузить(Настройки.Получить("ТЧМатериалы"));
       Объект.Поставщики.Загрузить(Настройки.Получить("ТЧПоставщики"));
   КонецЕсли;

КонецПроцедуры
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 07.08.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому