1С 8.3 БСП ПоказатьВопросПользователю - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП ПоказатьВопросПользователю

Данные > Примеры кода 1С > 1С 8.3 БСП > Стандартные подсистемы
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП ПоказатьВопросПользователю. Показать форму вопроса.
Примера кода от rayastar
СтандартныеПодсистемыКлиент.ПоказатьВопросПользователю(ОписаниеОповещенияОЗавершении, ТекстВопроса, Кнопки, ДополнительныеПараметры);

//
Параметры = СтандартныеПодсистемыКлиент.ПараметрыВопросаПользователю();
Параметры.ПредлагатьБольшеНеЗадаватьЭтотВопрос = Ложь;
Параметры.Заголовок = НСтр("ru = 'Записать документ'");
Параметры.КнопкаПоУмолчанию = "Записать";

СтандартныеПодсистемыКлиент.ПоказатьВопросПользователю(Обработчик,
   НСтр("ru = 'Для изменения типа документа требуется его записать. Записать?'"),   Кнопки,   Параметры);
Примера кода из ВопросПользователюSSL
// Возвращает новую структуру дополнительных параметров для процедуры ПоказатьВопросПользователю.
//
// Возвращаемое значение:
//  Структура:
//    * КнопкаПоУмолчанию             - Произвольный - определяет кнопку по умолчанию по типу кнопки или по связанному
//                                                     с ней значению.
//    * Таймаут                       - Число        - интервал времени в секундах до автоматического закрытия окна
//                                                     вопроса.
//    * КнопкаТаймаута                - Произвольный - кнопка (по типу кнопки или по связанному с ней значению),
//                                                     на которой отображается количество секунд, оставшихся до
//                                                     истечения таймаута.
//    * Заголовок                     - Строка       - заголовок вопроса.
//    * ПредлагатьБольшеНеЗадаватьЭтотВопрос - Булево - если Истина, то в окне вопроса будет доступен одноименный флажок.
//    * БольшеНеЗадаватьЭтотВопрос    - Булево       - принимает значение, выбранное пользователем в соответствующем
//                                                     флажке.
//    * БлокироватьВесьИнтерфейс      - Булево       - если Истина, форма вопроса открывается, блокируя работу всех
//                                                     остальных открытых окон, включая главное окно.
//    * Картинка                      - Картинка     - картинка, выводимая в окне вопроса.
//    * ТекстФлажка                   - Строка       - текст флажка "Больше не спрашивать".


&НаКлиенте
Процедура Команда1(Команда)

   ТекстВопроса = "Нажмите на кнопку для выбора задания";

   ДополнительныеПараметры       = СтандартныеПодсистемыКлиент.ПараметрыВопросаПользователю();

   ОповещениеОЗакрытии = Новый ОписаниеОповещения("ПослеВопросаСервер", ЭтотОбъект);

   ДопПараметры = СтандартныеПодсистемыКлиент.ПараметрыВопросаПользователю();

   ДопПараметры.КнопкаПоУмолчанию = 1;
   ДопПараметры.Таймаут = 10;
   ДопПараметры.КнопкаТаймаута  = 1;
   ДопПараметры.Заголовок = "Выбор выполнения задания";
   ДопПараметры.ПредлагатьБольшеНеЗадаватьЭтотВопрос = Ложь;
   //
   //Кнопки = РежимДиалогаВопрос.ДаНетОтмена;
   //
   Кнопки = Новый СписокЗначений();
   Кнопки.Добавить(1,"Задание 1");
   Кнопки.Добавить(2,"Задание 2");
   Кнопки.Добавить(3,"Задание 3");
   Кнопки.Добавить(4,"Задание 4");
   Кнопки.Добавить(5,"Задание 5");

   СтандартныеПодсистемыКлиент.ПоказатьВопросПользователю(ОповещениеОЗакрытии, ТекстВопроса, Кнопки, ДопПараметры);

КонецПроцедуры

&НаКлиенте
Процедура ПослеВопросаСервер(Ответ, ДополнительныеПараметры) Экспорт

   Если Ответ.Значение = 5 Тогда
       Сообщить("Нажата кнопка 5");
   ИначеЕсли Ответ.Значение = 4 Тогда
       Сообщить("Нажата кнопка 4");
   ИначеЕсли Ответ.Значение = 3 Тогда
       Сообщить("Нажата кнопка 3");
   ИначеЕсли Ответ.Значение = 2 Тогда
       Сообщить("Нажата кнопка 2");
   Иначе
       Сообщить("Нажата кнопка 1 (по умолчанию, спустя 10 сек)");
   КонецЕсли;

КонецПроцедуры
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 16.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому