1С 8.3 БСП ПолучитьРеквизитФормыПоПути - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП ПолучитьРеквизитФормыПоПути

Данные > Примеры кода 1С > 1С 8.3 БСП > Формы
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП ПолучитьРеквизитФормыПоПути. Получает значение реквизита формы.
Примера кода от rayastar
Результат = ОбщегоНазначенияКлиентСервер.ПолучитьРеквизитФормыПоПути(Форма, ПутьРеквизита);

//
ДанныеДолжности = ОбщегоНазначенияКлиентСервер.ПолучитьРеквизитФормыПоПути(Форма, "ДанныеДолжности");

//
Функция ФормаДокументаГотоваДляРасчетаЗарплаты(Форма, ОписаниеДокумента, СообщатьПользователю = Истина) Экспорт

   Отказ = Ложь;
   Для Каждого ОписаниеПоля Из ОписаниеДокумента.ОбязательныеПоля Цикл
       ЗначениеРеквизита = ОбщегоНазначенияКлиентСервер.ПолучитьРеквизитФормыПоПути(Форма, ОписаниеПоля.ПутьКРеквизиту);
       Если Не ЗначениеЗаполнено(ЗначениеРеквизита) Тогда
           Отказ = Истина;
           Если СообщатьПользователю Тогда
               ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru = 'Поле ""%1"" не заполнено';
|en = 'Field ""%1"" is blank'"), ОписаниеПоля.ИмяПоля);
               ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения, , ОписаниеПоля.ПутьКРеквизиту);
           КонецЕсли;
       КонецЕсли;
   КонецЦикла;

   Возврат Не Отказ;

КонецФункции
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 02.08.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому