1С 8.3 БСП ПользовательИБЗанят - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП ПользовательИБЗанят

Данные > Примеры кода 1С > 1С 8.3 БСП > Пользователи
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП ПользовательИБЗанят. Проверяет, сопоставлен ли пользователь ИБ с элементом справочника Пользователи или с элементом справочника ВнешниеПользователи.
Примера кода от rayastar
Результат = Пользователи.ПользовательИБЗанят(ПользовательИБ, УчетнаяЗапись);

//
Функция СсылкаПользователяПоПолномуНаименованию(ПолноеИмя)

   УстановитьПривилегированныйРежим(Истина);

   Запрос = Новый Запрос;
   Запрос.Текст =
                        "ВЫБРАТЬ
                        |    Пользователи.Ссылка КАК Ссылка,
                        |    Пользователи.ИдентификаторПользователяИБ
                        |ИЗ
                        |    Справочник.Пользователи КАК Пользователи
                        |ГДЕ
                        |    Пользователи.Наименование = &ПолноеИмя";

   Запрос.УстановитьПараметр("ПолноеИмя", ПолноеИмя);

   РезультатЗапроса = Запрос.Выполнить();
   Если НЕ РезультатЗапроса.Пустой() Тогда

       Выборка = РезультатЗапроса.Выбрать();
       Выборка.Следующий();

       Если НЕ Пользователи.ПользовательИБЗанят(Выборка.ИдентификаторПользователяИБ) Тогда
           Результат = Выборка.Ссылка;
       КонецЕсли;
   КонецЕсли;

   Возврат Результат;

КонецФункции

// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 23.08.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому