1С 8.3 БСП Проверить - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП Проверить

Данные > Примеры кода 1С > 1С 8.3 БСП > Данные
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП Проверить. Вызывает исключение с текстом Сообщение, если Условие не равно Истина. Применяется для самодиагностики кода.
Примера кода от rayastar
ОбщегоНазначенияКлиентСервер.Проверить(Условие, Сообщение, КонтекстПроверки);

//
ОбщегоНазначенияКлиентСервер.Проверить(МаксимальнаяДлина >= 32,
   НСтр("ru = 'Параметр МаксимальнаяДлина не может быть меньше 32'"),
"ОбщегоНазначения.СократитьСтрокуКонтрольнойСуммой");
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Метод БСП
// Вызывает исключение с текстом Сообщение, если Условие не равно Истина.
// Применяется для самодиагностики кода.
//
// Параметры:
//   Условие - Булево - если не равно Истина, то вызывается исключение.
//   Сообщение - Строка - текст сообщения. Если не задан, то исключение вызывается с сообщением по умолчанию.
//   КонтекстПроверки - Строка - например, имя процедуры или функции, в которой выполняется проверка.
//
Процедура Проверить(Знач Условие, Знач Сообщение = "", Знач КонтекстПроверки = "") Экспорт

   Если Условие <> Истина Тогда

       Если ПустаяСтрока(Сообщение) Тогда
           ТекстИсключения = НСтр("ru = 'Недопустимая операция'"); // Assertion failed
       Иначе
           ТекстИсключения = Сообщение;
       КонецЕсли;

       Если Не ПустаяСтрока(КонтекстПроверки) Тогда
           ТекстИсключения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
               НСтр("ru = '%1 в %2'"), ТекстИсключения, КонтекстПроверки);
       КонецЕсли;

       ВызватьИсключение ТекстИсключения;

   КонецЕсли;

КонецПроцедуры
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 11.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому