1С 8.3 БСП ПроверитьНаличиеУчетнойЗаписиДляОтправкиПочты - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП ПроверитьНаличиеУчетнойЗаписиДляОтправкиПочты

Данные > Примеры кода 1С > 1С 8.3 БСП > Почтовые сообщения и e-mail
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП ПроверитьНаличиеУчетнойЗаписиДляОтправкиПочты. Если у пользователя нет настроенной учетной записи для отправки писем, то в зависимости от прав либо показывает помощник настройки новой учетной записи, либо выводит сообщение о невозможности отправки.
Примера кода от rayastar
РаботаСПочтовымиСообщениямиКлиент.ПроверитьНаличиеУчетнойЗаписиДляОтправкиПочты(ОбработчикРезультата);

//
&НаКлиенте
Процедура НачатьПроверкуУчетнойЗаписи()

   РаботаСПочтовымиСообщениямиКлиент.ПроверитьНаличиеУчетнойЗаписиДляОтправкиПочты(
       Новый ОписаниеОповещения("ЗавершитьПроверкуУчетнойЗаписи", ЭтотОбъект));

КонецПроцедуры

&НаКлиенте
Процедура ЗавершитьПроверкуУчетнойЗаписи(Результат, ДополнительныеПараметры) Экспорт

   Если Результат = Истина Тогда
       ЗаполнитьУчетнуюЗапись();
       Возврат;
   КонецЕсли;

   ПоказатьПредупреждение(Новый ОписаниеОповещения("ЗавершитьРаботуФормы", ЭтотОбъект),
       НСтр("ru = 'Для рассылки документов требуется настроенная для отправки учетная запись электронной почты."));

КонецПроцедуры
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 07.09.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому