1С 8.3 БСП РазобратьСтрокуСПочтовымиАдресами - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП РазобратьСтрокуСПочтовымиАдресами

Данные > Примеры кода 1С > 1С 8.3 БСП > Почтовые сообщения и e-mail
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП РазобратьСтрокуСПочтовымиАдресами. Функция проверяет, что введенная строка с email-адресами введена правильно.
Примера кода от rayastar
Результат = ОбщегоНазначенияКлиентСервер.РазобратьСтрокуСПочтовымиАдресами(СтрокаПереданныхАдресов, ВызыватьИсключение);

Если ТипЗнчКому = Тип("Строка") Тогда
   ПараметрыПисьма.Кому = ОбщегоНазначенияКлиентСервер.РазобратьСтрокуСПочтовымиАдресами(ПараметрыПисьма.Кому);
ИначеЕсли ТипЗнчКому <> Тип("Массив") Тогда
   ПараметрыПисьма.Вставить("Кому", Новый Массив);
КонецЕсли;


//
Функция СоставПочтовогоАдреса(Знач АдресЭП) Экспорт

   Если ЗначениеЗаполнено(АдресЭП) Тогда

       Попытка
           СтруктураАдресаЭП = ОбщегоНазначенияКлиентСервер.РазобратьСтрокуСПочтовымиАдресами(АдресЭП);
       Исключение
           ШаблонСообщения = НСтр("ru = 'Указан некорректный адрес электронной почты: %1 Ошибка: %2'");
           ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ШаблонСообщения, АдресЭП, ИнформацияОбОшибке().Описание);
           ВызватьИсключение(ТекстСообщения);
       КонецПопытки;

       Возврат СтруктураАдресаЭП;
   Иначе
       Возврат Неопределено;
   КонецЕсли;

КонецФункции
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 23.08.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому