1С 8.3 БСП СформироватьДанныеВыбораПользователя - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП СформироватьДанныеВыбораПользователя

Данные > Примеры кода 1С > 1С 8.3 БСП > Пользователи
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП СформироватьДанныеВыбораПользователя. Возвращает список пользователей, групп пользователей, внешних пользователей и групп внешних пользователей. Для использования в обработчиках событий ОкончаниеВводаТекста и АвтоПодбор.
Примера кода от rayastar
Результат = Пользователи.СформироватьДанныеВыбораПользователя(Текст, ВключаяГруппы, ВключаяВнешнихПользователей, БезПользователей);

//
&НаКлиенте
Процедура ПользователиПолноеПредставлениеОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, СтандартнаяОбработка)

   Если ЗначениеЗаполнено(Текст) Тогда
       СтандартнаяОбработка = Ложь;
       ДанныеВыбора = СформироватьДанныеВыбораПользователя(Текст);
   КонецЕсли;

КонецПроцедуры

&НаСервереБезКонтекста
Функция СформироватьДанныеВыбораПользователя(Знач Текст,
                                            Знач ВключаяГруппы = Истина,
                                            Знач ВключаяВнешнихПользователей = Неопределено,
                                            Знач БезПользователей = Ложь)

   Возврат Пользователи.СформироватьДанныеВыбораПользователя(
       Текст,
       ВключаяГруппы,
       ВключаяВнешнихПользователей,
       БезПользователей);

КонецФункции
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 23.08.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому