1С 8.3 БСП СохранитьФайл - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП СохранитьФайл

Данные > Примеры кода 1С > 1С 8.3 БСП > Файлы (сохранение)
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП СохранитьФайл. Получает файл и сохраняет его в локальную файловую систему пользователя.
Примера кода от rayastar
&НаКлиенте
Процедура Сформировать(Команда)

   Попытка
       Excel = Новый COMОбъект("Excel.Application");
       Excel.AutomationSecurity = 3;
       Excel.DisplayAlerts      = 0;
   Исключение
       СообщениеОбОшибке = НСтр("ru = 'Не удалось подключиться к Excel.
|Убедитесь, что на компьютере установлена программа Microsoft Excel.
|Подробности:'") + " " + КраткоеПредставлениеОшибки(ИнформацияОбОшибке());
       ВызватьИсключение СообщениеОбОшибке;
   КонецПопытки;

   ДополнительныеПараметры = Новый Структура();
   ДополнительныеПараметры.Вставить("Excel", Excel);

   ПараметрыСохранения = ФайловаяСистемаКлиент.ПараметрыСохраненияФайла();
   ПараметрыСохранения.Диалог.Фильтр = НСтр("ru = 'Файлы MS Excel (*.xlsx)|*.xlsx'");

   ФайловаяСистемаКлиент.СохранитьФайл(
       Новый ОписаниеОповещения("ПослеВыбораФайлаДляВыгрузки", ЭтотОбъект, ДополнительныеПараметры),
       АдресМакета,,
       ПараметрыСохранения);

КонецПроцедуры


//
// Сохраняет подпись на диск
Процедура СохранитьПодпись(АдресПодписи) Экспорт

   Оповещение = Новый ОписаниеОповещения("СохранитьПодписьПослеПолученияФайла", ЭтотОбъект, Неопределено);
   Фильтр = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
       НСтр("ru = 'Файлы электронных подписей (*.%1)|*.%1|Все файлы (*.*)|*.*'"),
       ЭлектроннаяПодписьКлиент.ПерсональныеНастройки().РасширениеДляФайловПодписи);

   ПараметрыСохранения = ФайловаяСистемаКлиент.ПараметрыСохраненияФайла();
   ПараметрыСохранения.Диалог.Фильтр = Фильтр;
   ПараметрыСохранения.Диалог.Заголовок = НСтр("ru = 'Выберите файл для сохранения подписи'");

   ФайловаяСистемаКлиент.СохранитьФайл(Оповещение, АдресПодписи, "", ПараметрыСохранения);

КонецПроцедуры

// Продолжение процедуры СохранитьПодпись.
Процедура СохранитьПодписьПослеПолученияФайла(ПолученныеФайлы, Контекст) Экспорт

   Если ПолученныеФайлы = Неопределено
    Или ПолученныеФайлы.Количество() = 0 Тогда
       Возврат;
   КонецЕсли;

   ПоказатьОповещениеПользователя(НСтр("ru = 'Электронная подпись сохранена в файл:'"),,ПолученныеФайлы[0].Имя);

КонецПроцедуры
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 04.09.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому