1С 8.3 БСП СоздатьАдминистратора - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП СоздатьАдминистратора

Данные > Примеры кода 1С > 1С 8.3 БСП > Пользователи
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП СоздатьАдминистратора. Используется при обновлении и начальном заполнении информационной базы. Создает первого администратора и сопоставляет его с новым или существующим пользователем в справочнике Пользователи
Примера кода от rayastar
Результат = Пользователи.СоздатьАдминистратора(ПользовательИБ);

//
&НаСервере
Процедура ЗаписатьПользователяСервер()

   ОписаниеПользователяИБ = Новый Структура;

   Если Не ТекущийПользователь.Пустая()
           И Справочники.Пользователи.НайтиПоНаименованию("") <> Неопределено
           И Справочники.Пользователи.НайтиПоНаименованию("") <> ТекущийПользователь Тогда
       Пользователь = ТекущийПользователь.ПолучитьОбъект();
   Иначе
       ПользовательИБ = ПользователиИнформационнойБазы.НайтиПоИмени(НаименованиеПользователя);

       Если ПользовательИБ = Неопределено Тогда

           ПользовательИБ = ПользователиИнформационнойБазы.СоздатьПользователя();
           ПользовательИБ.Имя       = ПользовательИнфБазыИмя;
           ПользовательИБ.ПолноеИмя = НаименованиеПользователя;
           ПользовательИБ.Пароль = Пароль;
           ПользовательИБ.Роли.Очистить();
           ПользовательИБ.Роли.Добавить(Метаданные.Роли.ПолныеПрава);
           РольАдминистратораСистемы = Метаданные.Роли.АдминистраторСистемы;
           Если НЕ ПользовательИБ.Роли.Содержит(РольАдминистратораСистемы) Тогда
               ПользовательИБ.Роли.Добавить(РольАдминистратораСистемы);
           КонецЕсли;
           ПользовательИБ.Записать();

       КонецЕсли;

       ОписаниеПользователяИБ.Вставить("Действие", "Записать");
       ОписаниеПользователяИБ.Вставить(
"УникальныйИдентификатор", ПользовательИБ.УникальныйИдентификатор);

       // Пользователи.СоздатьАдминистратора
       Пользователь = Пользователи.СоздатьАдминистратора(ПользовательИБ);

   КонецЕсли;

   ТекущийПользователь = Пользователь.Ссылка;

КонецПроцедуры
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 23.08.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому