1С 8.3 БСП УстановитьДоступностьЭлементовФормы - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП УстановитьДоступностьЭлементовФормы

Данные > Примеры кода 1С > 1С 8.3 БСП > Запрет редактирования реквизитов объектов
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП УстановитьДоступностьЭлементовФормы. Устанавливает доступность элементов формы, связанных с заданными реквизитами, для которых установлено разрешение изменения.
Примера кода от rayastar
ЗапретРедактированияРеквизитовОбъектовКлиент.УстановитьДоступностьЭлементовФормы(Форма, Реквизиты);

//
&НаКлиенте
Процедура Подключаемый_РазрешитьРедактированиеРеквизитовОбъекта(Команда)

   Если Не Объект.Ссылка.Пустая() Тогда
       ОткрытьФорму("Справочник.Кассы.Форма.РазблокированиеРеквизитов",,,,,,
           Новый ОписаниеОповещения("Подключаемый_РазрешитьРедактированиеРеквизитовОбъектаЗавершение", ЭтотОбъект),
           РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
   КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_РазрешитьРедактированиеРеквизитовОбъектаЗавершение(Результат, ДополнительныеПараметры) Экспорт

   Если ТипЗнч(Результат) = Тип("Массив") И Результат.Количество() > 0 Тогда
       ЗапретРедактированияРеквизитовОбъектовКлиент.УстановитьДоступностьЭлементовФормы(ЭтаФорма, Результат);
   КонецЕсли;

КонецПроцедуры
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 06.09.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому