1С 8.3 БСП ВходВПрограммуРазрешен - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП ВходВПрограммуРазрешен

Данные > Примеры кода 1С > 1С 8.3 БСП > Пользователи
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП ВходВПрограммуРазрешен. Проверяет наличие хотя бы одного вида аутентификации у пользователя ИБ.
Примера кода от rayastar
Результат = Пользователи.ВходВПрограммуРазрешен(ОписаниеПользователяИБ);

//
Процедура ОчиститьРеквизитВходВПрограммуРазрешенУВсехПользователей()

   ПользователиИБ = ПользователиИнформационнойБазы.ПолучитьПользователей();
   Для Каждого ПользовательИБ Из ПользователиИБ Цикл
       Если Пользователи.ВходВПрограммуРазрешен(ПользовательИБ) Тогда
           ПользовательИБ.АутентификацияСтандартная = Ложь;
           ПользовательИБ.Записать();
       КонецЕсли;
   КонецЦикла;

КонецПроцедуры
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 23.08.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому