1С 8.3 БСП ЗадатьОбластьПечатиДокумента - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП ЗадатьОбластьПечатиДокумента

Данные > Примеры кода 1С > 1С 8.3 БСП > Печать
Перейти в раздел примеры кода 1С 8.3:
Примера кода от rayastar
Пока ВыборкаПоДокументам.Следующий() Цикл

   НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;
   // ... вывод печатной формы в табличный документ ...
   УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент, НомерСтрокиНачало,     ОбъектыПечати, ВыборкаПоДокументам.Ссылка);

КонецЦикла;


//
Функция ТабличныйДокументСправки(МассивСсылок, ОбъектыПечати)

   ТабличныйДокумент = Новый ТабличныйДокумент;
   ТабличныйДокумент.КлючПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СправкаОЗаработкеДляРасчетаПособий";
   ТабличныйДокумент.АвтоМасштаб = Истина;

   ДанныеДокументов = ЗапросПоОсновнымДанным(МассивСсылок).Выполнить().Выгрузить();
   ПервыйДокумент = Истина;
   Для Каждого ДанныеДокумента Из ДанныеДокументов Цикл

       Если ПервыйДокумент Тогда
           ПервыйДокумент = Ложь;
       Иначе
           ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
       КонецЕсли;

       НачалоТекущегоФрагмента = ТабличныйДокумент.ВысотаТаблицы + 1;

       ВывестиШапку(ТабличныйДокумент, СоставМакета.Шапка, ДанныеДокумента, АдресаОрганизаций);
       ВывестиЗаработок(ТабличныйДокумент, СоставМакета, СтруктураПоиска, ВыборкаЗаработка, Валюта);
       ВывестиПодвал(ТабличныйДокумент, СоставМакета.Подвал, ДанныеДокумента, КадровыеДанныеФизическихЛиц);

       // В табличном документе зададим имя области, в которую был
       // выведен объект. Нужно для возможности печати покомплектно.
       УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент, НачалоТекущегоФрагмента, ОбъектыПечати, ДанныеДокумента.Ссылка);
   КонецЦикла;

   Возврат ТабличныйДокумент;

КонецФункции
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 24.08.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому