1С 8.3 БСП ЗагрузитьФайлы - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП ЗагрузитьФайлы

Данные > Примеры кода 1С > 1С 8.3 БСП > Файлы (загрузка)
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП ЗагрузитьФайлы. Показывает диалог выбора файлов и помещает выбранные файлы во временное хранилище.
Примера кода от rayastar
&НаКлиенте
Процедура ФайлыПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)

   Отказ = Истина;
   ПараметрыЗагрузки = ФайловаяСистемаКлиент.ПараметрыЗагрузкиФайла();
   ПараметрыЗагрузки.ИдентификаторФормы = УникальныйИдентификатор;

   ДиалогВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
   ДиалогВыбораФайла.Фильтр = ФильтрДляВыбораФайлов();
   ДиалогВыбораФайла.Заголовок = НСтр("ru = 'Выберите файлы'");

   ПараметрыЗагрузки.Диалог = ДиалогВыбораФайла;
  ОповещениеЗавершенияВыбораФайла = Новый ОписаниеОповещения("ОбработкаВыбораФайла", ЭтотОбъект);
  ФайловаяСистемаКлиент.ЗагрузитьФайлы(ОповещениеЗавершенияВыбораФайла, ПараметрыЗагрузки);

КонецПроцедуры

&НаКлиенте
Процедура ОбработкаВыбораФайла(Результат, ДополнительныеПараметры) Экспорт

   Если Результат = Неопределено Тогда
       Возврат;
   КонецЕсли;

   Для Каждого Файл Из Результат Цикл
       ОписаниеФайла = ОбщегоНазначенияКлиентСервер.РазложитьПолноеИмяФайла(Файл.Имя);
       Поиск = Новый Структура("Имя", ОписаниеФайла.Имя);
       СуществующиеСтроки = Файлы.НайтиСтроки(Поиск);
       Если ЗначениеЗаполнено(СуществующиеСтроки) Тогда
           Продолжить;
       КонецЕсли;
       Строка = Файлы.Добавить();
       Строка.Имя = ОписаниеФайла.Имя;
       Строка.Хранение = Файл.Хранение;
       Строка.Расширение = ОбщегоНазначенияКлиентСервер.РасширениеБезТочки(ОписаниеФайла.Расширение);
       Строка.Номер = Файлы.Количество();
   КонецЦикла;

КонецПроцедуры
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 04.09.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому