1С 8.3 БСП ЗагрузитьПочтовыеСообщения - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП ЗагрузитьПочтовыеСообщения

Данные > Примеры кода 1С > 1С 8.3 БСП > Почтовые сообщения и e-mail
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП ЗагрузитьПочтовыеСообщения. Загружает сообщения с сервера электронной почты для указанной учетной записи.
Примера кода от rayastar
Результат = РаботаСПочтовымиСообщениями.ЗагрузитьПочтовыеСообщения(УчетнаяЗапись, ПараметрыЗагрузки);

//
Функция ЗагрузитьПочтовыеСообщенияПоЭДО(РесурсОбмена)

   ПараметрыЗагрузкиЗаголовков = Новый Структура;
   ПараметрыЗагрузкиЗаголовков.Вставить("ПолучениеЗаголовков", Истина);
   ПараметрыЗагрузкиЗаголовков.Вставить("ПриводитьСообщенияКТипу", Ложь);

   НаборСообщений = РаботаСПочтовымиСообщениями.ЗагрузитьПочтовыеСообщения(
       РесурсОбмена.УчетнаяЗаписьЭлектроннойПочты, ПараметрыЗагрузкиЗаголовков);

   Если Не ЗначениеЗаполнено(НаборСообщений) Тогда
       Возврат НаборСообщений;
   КонецЕсли;

   Для Каждого Сообщение Из НаборСообщений Цикл

       АдресОтправителя = НРег(?(ТипЗнч(Сообщение.Отправитель) = Тип("Строка"),
           Сообщение.Отправитель, Сообщение.Отправитель.Адрес));

   КонецЦикла;

   Возврат НаборСообщений

КонецФункции
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 07.09.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому