1С 8.3 Инициализация типом - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Инициализация типом

Данные > Примеры кода 1С > 1С 8.3 Описание типов
Создает в переданной переменной указанный тип через конструктор Новый или вызывает метод очистки в 1С 8.3:
Процедура ИнициализацияТипом(Переменная,ТипДанных = "СписокЗначений",Очищать = Истина)

   Если Переменная = Неопределено Тогда
       Переменная = Вычислить("Новый " + ТипДанных);
   ИначеЕсли ТипЗнч(Переменная) = Тип("СписокЗначений")
  Или ТипЗнч(Переменная) = Тип("Массив") Или ТипЗнч(Переменная) = Тип("ТаблицаЗначений") Тогда
       Если Очищать = Истина Тогда
           Переменная.Очистить();
       КонецЕсли;
   КонецЕсли;

КонецПроцедуры

0
комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 13.02.2023
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому