1С 8.3 Настроить режим сложности паролей - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Настроить режим сложности паролей

Данные > Примеры кода 1С > 1С 8.3 Пользователи, роли (права) доступа
Перейти в раздел примеры кода 1С 8.3:
Программно настроить режим сложности паролей в базе данных 1С 8.3:
    // Проверяет, установлен ли в инфобазе режим проверки сложности пользовательских паролей,
     // и если по каким-то причинам этот режим был выключен - включает его.
     //
     // Параметры:
     // нет.
     //
     Процедура НастроитьРежимСложностиПаролей() Экспорт

         ПроверкаВключена = ПолучитьПроверкуСложностиПаролейПользователей();
         Длина = ПолучитьМинимальнуюДлинуПаролейПользователей();

         // Устанавливаем правило "Пароль не короче 8 символов".
         Если Длина < 8 Тогда
             УстановитьМинимальнуюДлинуПаролейПользователей(8);
         КонецЕсли;

         // Устанавливаем правило "пароль должен быть сложным".
         Если Не ПроверкаВключена Тогда
             УстановитьПроверкуСложностиПаролейПользователей(Истина);
         КонецЕсли;

     КонецПроцедуры // НастроитьРежимСложностиПаролей()
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 08.08.2022
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому