1С 8.3 Подключение расширения для работы с файлами - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Подключение расширения для работы с файлами

Данные > Примеры кода 1С > 1С 8.3 Файлы, каталоги
Перейти в раздел примеры кода 1С 8.3:
Для работы с файлами и криптографией в веб-клиенте требуется наличие специальных расширений, установленных в используемом веб-браузере. Например, при использовании Google Chrome, перед установкой расширений платформы, необходимо выполнить установку расширения веб-браузера: Расширение для работы с 1С:Предприятием, которое устанавливается из интернет-магазина Chrome. Без установки этого расширения будет невозможно использование расширений платформы. Начиная с версии 8.3.18 доступна асинхронная функция УстановитьРасширениеРаботыСФайламиАсинх(), которая устанавливает расширение работы с файлами. В режиме запуска толстого и тонкого клиентов информирует о том, что расширение установлено. Для клиента мобильного приложения, информирует о том, что расширение установлено.
Установка Расширения если РежимИспользованияМодальности = Использовать в 1С 8.3 (от пользователя master1c8):
&НаКлиенте
Процедура СинхронноеПодключение(Команда)

    #Если ВебКлиент Тогда
       ПодключитьРасширение = ПодключитьРасширениеРаботыСФайлами();
       ПодключитьРасширение = Ложь;
       // Если подключить не удалось - требуется установить его (один раз)
       Если Не ПодключитьРасширение Тогда
           // Устанавливаем...
           УстановитьРасширениеРаботыСФайлами();
           // Если не удалось установить - то повторный вызов подключения будет неудачный
           Если Не ПодключитьРасширениеРаботыСФайлами() Тогда
               // Сообщаем об ошибке и прерываем работу программы
               ВызватьИсключение "Ваш браузер не поддерживает работу с файлами. Не удалось подключить расширение работы с файлами!";
           КонецЕсли;
       КонецЕсли;
    #КонецЕсли

   Состояние("Ждите…. Идет чтение файла.");
   //ЗагрузитьИзФайлаДанные(); // Пользовательская процедура

КонецПроцедуры
Установка Расширения если РежимИспользованияМодальности = Не Использовать ИЛИ Использовать с предупреждениями в 1С 8.3 (от пользователя master1c8):
&НаКлиенте
Процедура АсинхронноеПодключение(Команда)
   ПодключитьРасширение(Истина);
КонецПроцедуры

&НаКлиенте
Процедура ПодключитьРасширение(Установить) Экспорт
   НачатьПодключениеРасширенияРаботыСФайлами(Новый ОписаниеОповещения("ПослеПодключения", ЭтотОбъект, Установить));
КонецПроцедуры

&НаКлиенте
Процедура ПослеПодключения(Подключено,Установить) Экспорт

   Если Подключено Тогда
       Состояние("Ждите…. Идет чтение файла.");
       //ЗагрузитьИзФайлаДанные(); // Пользовательская процедура
   ИначеЕсли Установить Тогда
       НачатьУстановкуРасширенияРаботыСФайлами(Новый ОписаниеОповещения("ПодключитьРасширение", ЭтотОбъект, Ложь));
   Иначе
       ВызватьИсключение "Ваш браузер не поддерживает работу с файлами. Не удалось подключить расширение работы с файлами!";
   КонецЕсли;

КонецПроцедуры
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 27.07.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому