1С 8.3 Получение элементов по выделенным строкам в табличной части документа - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Получение элементов по выделенным строкам в табличной части документа

Данные > Примеры кода 1С > 1С 8.3 Документы
Перейти в раздел примеры кода 1С 8.3:
Получить выделенные строки (ссылки, элементы) списка в 1С 8.3 (от Юрий):
&НаКлиенте
Функция ПолучениеЭлементовПоВыделеннымСтрокам(ВыбЭлемент, ПолеСсылка) Экспорт

   ЭлементыВыделенныхСтрок = Новый Массив();
   ВыделенныеСтроки = Новый Массив();

   // Заполняем массив выделенными строками
   Для Каждого СтрокаВыбЭлемента Из ВыбЭлемент.ВыделенныеСтроки Цикл
       ВыделенныеСтроки.Добавить(СтрокаВыбЭлемента);
   КонецЦикла;

   // Получаем элементы и ссылки выделенных строк
   Для Каждого ТекВыдСтрока Из ВыделенныеСтроки Цикл
       ВыбЭлемент.ТекущаяСтрока = ТекВыдСтрока;
       СсылкаНаЭлемент = ВыбЭлемент.ТекущиеДанные[ПолеСсылка];
       ЭлементыВыделенныхСтрок.Добавить(СсылкаНаЭлемент);
   КонецЦикла;

   // Сохраняем выделение
   Для Каждого ТекВыдСтрока Из ВыделенныеСтроки Цикл
       ВыбЭлемент.ВыделенныеСтроки.Добавить(ТекВыдСтрока);
   КонецЦикла;

   Возврат ЭлементыВыделенныхСтрок;

КонецФункции
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 01.11.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому