1С 8.3 Получить IP адрес - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Получить IP адрес

Данные > Примеры кода 1С > 1С 8.3 Приложение, система, интерфейс
Перейти в раздел примеры кода 1С 8.3:
Пример №1: программно получить локальный IP адрес в 1С 8.3:
&НаКлиенте
Процедура ПолучитьIP_1()

   COMОбъектRS= Новый COMОбъект("rcbdyctl.setting");
   IPадрес=COMОбъектRS.GetIpAddress;
   Сообщить("IP адрес устройства = "+ IPадрес);

КонецПроцедуры
Пример №2: программно получить локальный IP адрес в 1С 8.3:
&НаКлиенте
Процедура ПолучитьIP_2()

   COMОбъектWS = Новый COMОбъект("WbemScripting.SWbemLocator");
   COMОбъектWS_root = COMОбъектWS.ConnectServer(".","root\CIMV2");

   ПулСтрок = COMОбъектWS_root.ExecQuery("SELECT IPAddress FROM
                                                                        |Win32_NetworkAdapterConfiguration
                                                                        |WHERE IPEnabled = TRUE");

   Для Каждого СтрIP Из ПулСтрок Цикл
       Для Каждого IPадрес Из СтрIP.IPAddress Цикл
           Сообщить("IP адрес устройства = "+ IPадрес);
       КонецЦикла;
   КонецЦикла;

КонецПроцедуры

Пример №3: программно получить локальный IP адрес в 1С 8.3:
&НаКлиенте
Процедура ПолучитьIP_3()
   // Аналогичен примеру №2 (разница лишь в подключении)

   COMОбъектWin = ПолучитьCOMОбъект("winmgmts:\\.\root\CIMV2");
   ПулСтрок = COMОбъектWin.ExecQuery("SELECT * FROM
                                                                 |Win32_NetworkAdapterConfiguration
                                                                 |WHERE IPEnabled = TRUE");
   Для Каждого СтрIP Из ПулСтрок Цикл
       Для Каждого IPадрес Из СтрIP.IPAddress Цикл
           Сообщить("IP адрес устройства = "+ IPадрес);
       КонецЦикла;
   КонецЦикла;

КонецПроцедуры
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 26.02.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому