1С 8.3 Как программно получить основную организацию - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Как программно получить основную организацию

Данные > Примеры кода 1С > 1С 8.3 Типовые (БП3, ЗУП, УТ)
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 Типовые
Программно получить по умолчанию осн.организацию в 1С 8.3 Бухгалтерия предприятия:
Процедура ПолучитьОсновнаяОрганизация() Экспорт

         ОсновнаяОрганизация = БухгалтерскийУчетПереопределяемый.ПолучитьЗначениеПоУмолчанию("ОсновнаяОрганизация");
         //ОсновнаяОрганизация = Справочники.Организации.ОрганизацияПоУмолчанию(Пользователь);
         //ОсновнаяОрганизация = глЗначениеПеременной("ОсновнаяОрганизация");

КонецПроцедуры

Функция ПолучитьОсновнаяОрганизация() Экспорт

         ОсновнаяОрганизация = Справочники.Организации.ПустаяСсылка();

         Запрос = Новый Запрос;
         Запрос.Текст =
        "ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 2
        |    Организации.Ссылка КАК Организация
        |ИЗ
        |    Справочник.Организации КАК Организации
        |ГДЕ
        |    НЕ Организации.ПометкаУдаления
        |    И НЕ Организации.Предопределенный";

         Выборка = Запрос.Выполнить().Выбрать();
         Если Выборка.Следующий() И Выборка.Количество() = 1 Тогда
             ОсновнаяОрганизация = Выборка.Организация;
         КонецЕсли;

         Возврат ОсновнаяОрганизация;

КонецФункции

Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 22.03.2022
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому