1С 8.3 Получить свойства файла - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Получить свойства файла

Данные > Примеры кода 1С > 1С 8.3 Файлы, каталоги
Перейти в раздел примеры кода 1С 8.3:
Узнать свойства файла в 1С 8.3:
Процедура ПолучитьСвойстваФайла() Экспорт

   СистемнаяИнфо = Новый СистемнаяИнформация;
   ТипПлатформы = СистемнаяИнфо.ТипПлатформы;

   Если ТипПлатформы = ТипПлатформы.Windows_x86
       Или ТипПлатформы = ТипПлатформы.Windows_x86_64 Тогда

       НовыйФайл = Новый Файл("ИмяФайла");
       Оболочка = Новый COMОбъект("Shell.Application");
       Имена = Оболочка.NameSpace(НовыйФайл.Путь);

       Парсинг = Имена.ParseName(Сред(НовыйФайл.ПолноеИмя, СтрНайти(НовыйФайл.ПолноеИмя, "\", НаправлениеПоиска.СКонца) + 1));
       Для Счетчик = -100 По 500 Цикл
           Попытка
               Сообщить(Счетчик + "     |" + Имена.GetDetailsOf(Неопределено, Счетчик) + "     |" + Имена.GetDetailsOf(Парсинг, Счетчик));
           Исключение
           КонецПопытки;
       КонецЦикла;
   Иначе
       //Сообщить("Данная функция поддерживается только в ОС Windows");
   КонецЕсли;

КонецПроцедуры
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 27.11.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому