1С 8.3 Получить значение из списка значений по представлению - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Получить значение из списка значений по представлению

Данные > Примеры кода 1С > 1С 8.3 Список значений
Перейти в раздел примеры кода 1С 8.3:
Получить значение по представлению в 1С 8.3:
&НаСервере
Функция ЗначениеПоПредставлению(СписокЗначений, ВходящееПредставление)

   Результат = Неопределено;
   Для НомерПП = 0 По СписокЗначений.Количество()-1 Цикл
       ЭлементСЗ = СписокЗначений.Получить(НомерПП);
       Если ВходящееПредставление = ЭлементСЗ.Представление Тогда
           Возврат ЭлементСЗ.Значение;
       КонецЕсли;
   КонецЦикла;

   Возврат Результат;

КонецФункции


&НаСервере
Функция ПодобратьОсновнойСчет(Стр_К) // Для примера

   СписокЗначений = Новый СписокЗначений;
   СписокЗначений.Добавить(Стр_К.C_Fir, "КодФирмы");
   СписокЗначений.Добавить(Стр_К.FIR_NAME, "Наименование");
   СписокЗначений.Добавить(Стр_К.ORGAN, "ПолнНаименование");
   СписокЗначений.Добавить(Стр_К.ADR, "ЮридическийАдрес");
   СписокЗначений.Добавить(Стр_К.FADR, "ПочтовыйАдрес");
   СписокЗначений.Добавить(Стр_К.TEL, "Телефоны");
   СписокЗначений.Добавить(Стр_К.BANK1, "НомерСчета");
   СписокЗначений.Добавить(Стр_К.BANK2, "НаименованиеБанка");
   СписокЗначений.Добавить(Стр_К.CORRS, "КоррСчетБанка");
   СписокЗначений.Добавить(Стр_К.BIK, "БИКБанка");
   СписокЗначений.Добавить(Стр_К.INN, "ИНН_КПП");
   СписокЗначений.Добавить(Стр_К.OKPO, "ОКПО");
   СписокЗначений.Добавить(Стр_К.DIR, "Руководитель");
   СписокЗначений.Добавить(Стр_К.BUX, "ГлБух");
   СписокЗначений.Добавить(Стр_К.CONT, "КонтактноеЛицо");
   СписокЗначений.Добавить(Стр_К.EMAIL, "ЭлАдрес");

   НомерСчета = ЗначениеПоПредставлению(СписокЗначений, "НомерСчета");

  Возврат НомерСчета;

КонецФункции
0
комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 04.12.2023
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому