1С 8.3 Программное поздравление программиста 1С с днем рождения - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Программное поздравление программиста 1С с днем рождения

Данные > Примеры кода 1С > 1С 8.3 Приложение, система, интерфейс
Перейти в раздел примеры кода 1С 8.3:
Данный код шуточный и не работает. Это оригинальное поздравление программиста 1С. При попытке вставки и сохранении данного куска кода в конфигураторе 1С. Получите ошибку:
{Обработка.Тест.Форма.Форма.Форма(5,23)}: Тип не определен (Поздравление)
Поздравление = Новый<>СписокПожеланий; (Проверка: Сервер)
Как пользоваться: скопируйте код в мессенджер или соц.сеть, вставьте ФИО именинника и отправьте ему.
Копи-паста с телеграм группы@ 1С 8.3:
Процедура Поздравить() Экспорт //Поздравление.Поздравить();

   Поздравление = Новый Поздравление;
   Поздравление.Текст = "Поздравляю с днем рождения!";

   СписокПожеланий = Новый СписокПожеланий;
   СписокПожеланий.Добавить("Счастья");
   СписокПожеланий.Добавить("Здоровья");
   СписокПожеланий.Добавить("Здоровья родным и близким");
   СписокПожеланий.Добавить("Успехов");
   СписокПожеланий.Добавить("Богатства");
   СписокПожеланий.Добавить("Самых интересных проектов");
   СписокПожеланий.Добавить("Всего всего что только можно пожелать");

   Для стр = 1 По Бесконечность Цикл
       Пожелания = Поздравление.Пожелания.Добавить;
       Пожелания.ЗаполнитьПожелания(СписокПожеланий);
       Если УсталЖдатьКонца Тогда
           Прервать;
       КонецЕсли;
   КонецЦикла

КонецПроцедуры

Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 20.10.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому