1С 8.3 Преобразование строки в URL - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Преобразование строки в URL

Данные > Примеры кода 1С > 1С 8.3 Строка, текст, буквы
Перекодирование строки в URL в 1С 8.3:
&НаСервере
Функция ПреобразованиеСтрокиВURL(Строка)

   Возврат КодироватьСтроку(Строка, СпособКодированияСтроки.КодировкаURL , "windows-1251"); // "UTF-8"

КонецФункции
Перекодирование строки в URL (и обратно) через COM в 1С 8.3:
Функция ПреобразованиеСтрокиВURLчерезCOM(Строка="")

   Компонент = Новый COMОбъект("MSScriptControl.ScriptControl");
   Компонент.Language="JScript";
   СтрокаВURL = Компонент.eval("var uri='"+Строка+"'; encodeURI(uri);"); //encode

   Возврат СтрокаВURL;

КонецФункции

Функция ПреобразованиеURLВСтрокучерезCOM(Строка="")

   Компонент = Новый COMОбъект("MSScriptControl.ScriptControl");
   Компонент.Language="JScript";
   URLвСтроку = Компонент.eval("var uri='"+Строка+"'; decodeURI(uri);"); //decode

   Возврат URLвСтроку;

КонецФункции
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 06.11.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому