1С 8.3 Программно подчеркнуть текст в макете - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Программно подчеркнуть текст в макете

Данные > Примеры кода 1С > 1С 8.3 Табличный документ / Макет
Подчеркнуть текст в 1С 8.3:
Функция ПодчеркнутьТекст(ВходящаяСтрока) Экспорт

   ПодчёркнутаяСтрока = "";
   Для а = 1 По СтрДлина(ВходящаяСтрока) Цикл
       Если Найти(" _-", Сред(ВходящаяСтрока, а, 1)) = 0 Тогда
           ПодчёркнутаяСтрока = ПодчёркнутаяСтрока + Символ(863); // подчеркивание "_"
       КонецЕсли;
       ПодчёркнутаяСтрока = ПодчёркнутаяСтрока + Сред(ВходящаяСтрока, а, 1);
   КонецЦикла;

   Возврат ПодчёркнутаяСтрока;

КонецФункции
0
комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 18.12.2023
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому