1С 8.3 Программно восстановить положение окна - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Программно восстановить положение окна

Данные > Примеры кода 1С > 1С 8.3 Форма, элементы
Перейти в раздел примеры кода 1С 8.3:
Универсальное решение в 1С 8.3:
//Для программного сброса отображения формы
//(замена действия: Окно - Восстановить положение):
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   КлючСохраненияПоложенияОкна = Новый УникальныйИдентификатор;
КонецПроцедуры
В процедуре МеханизмНумерацииОбъектов.УстановитьДоступностьПоляВводаНомера в 1С 8.3:
// Форма - форма документа
// Источник - объект документа.
Если НЕ Форма.СпособОтображенияОкна = ВариантСпособаОтображенияОкна.Максимизированное Тогда
   Форма.Модифицированность=Ложь;
   Форма.Закрыть();

   НоваяФорма = Источник.ПолучитьФорму();
   НоваяФорма.СпособОтображенияОкна = ВариантСпособаОтображенияОкна.Максимизированное;
   НоваяФорма.Открыть();

   Shell = Новый COMОбъект("WScript.Shell");
   Shell.SendKeys("%+R"); // вызов Alt+Shift+R
КонецЕсли;
Для устаревших версий 8.1, 8.2:
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
   ЭтаФорма.ИмяСохраненияПоложенияОкна = Новый УникальныйИдентификатор();
КонецПроцедуры
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 31.05.2022
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому