1С 8.3 Программное создание динамической кнопки - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Программное создание динамической кнопки

Данные > Примеры кода 1С > 1С 8.3 Форма, элементы
Пример программного создания динамических кнопок в 1С 8.3:
&НаКлиенте
Процедура ДобавитьКоманду(Команда)
   ДобавитьКомандуНаСервере();
КонецПроцедуры

&НаСервере
Процедура ДобавитьКомандуНаСервере()

   НомерКнопки = НомерКнопки + 1;
   ИмяКоманды = "Кнопка"+Строка(НомерКнопки);
   НоваяКоманда = Команды.Добавить(ИмяКоманды);
   НоваяКоманда.Действие = "ВыполнитьКоманду";
   НоваяКоманда.Заголовок = ИмяКоманды;
   НовыйЭлемент = Элементы.Добавить("Элемент"+ИмяКоманды,
                                    Тип("КнопкаФормы"),
                                    ЭтаФорма.КоманднаяПанель);

   НовыйЭлемент.ИмяКоманды = ИмяКоманды;

КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьКоманду(Команда) // Нажатие кнопки
   Сообщить("Нажата кнопка: "+Команда.Имя);
КонецПроцедуры
Скачать обработку с примером создания дин.кнопок: https://koder.by/files/SozdanieDinamicheskojKnopki_koder_by.rar
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 26.05.2022
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому