1С 8.3 Проверка счета на группу для регистра бухгалтерии - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Проверка счета на группу для регистра бухгалтерии

Данные > Примеры кода 1С > 1С 8.3 Регистры бухгалтерии
Перейти в раздел примеры кода 1С 8.3:
Пример проверки счета на группу в 1С 8.3 (от МaximL) :
Процедура ПриЗаписи(Отказ, РежимЗаписи)

   Запрос = Новый Запрос;
   Запрос.Текст = "ВЫБРАТЬ
    |    Хозрасчетный.Код КАК Код,
    |   Хозрасчетный.Родитель.Код КАК РодительКод
    |ИЗ
    |    ПланСчетов.Хозрасчетный КАК Хозрасчетный
    |ГДЕ
    |    Хозрасчетный.Родитель В (&СчетДт,СчетКт)";

   СчетДт = ЭтотОбъект[0].СчетДт;
   СчетКт = ЭтотОбъект[0].СчетКт;

   Запрос.УстановитьПараметр("СчетДт", СчетДт);
   Запрос.УстановитьПараметр("СчетКт", СчетКт);

   РезультатЗапроса = Запрос.Выполнить();
   Если НЕ РезультатЗапроса.Пустой() Тогда
       ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
       Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
           Если СтрНайти(ВыборкаДетальныеЗаписи.Код, ".") Тогда
               Отказ = Истина;
               Сообщить("Некорретный номер счета - " + ВыборкаДетальныеЗаписи.РодительКод);
           КонецЕсли;
       КонецЦикла;
   КонецЕсли;

КонецПроцедуры
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 08.06.2022
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому