1С 8.3 Проверка строки на кириллицу - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Проверка строки на кириллицу

Данные > Примеры кода 1С > 1С 8.3 Строка, текст, буквы
Проверка на наличие Кириллицы в строке в 1С 8.3:
Функция ПроверкаСтрокиНаКириллицу(СтрТекст, ТекДок)

   СтрТекстДок      = СокрЛП(СтрТекст);
   СтрТекстДок      = Нрег(СтрТекстДок);
   ДлинаСтрокиНомера = СтрДлина(СтрТекстДок);
   СимволыКирилицы = "абвгдеёжзийклмнопрстуфхцчшщъыьэюя";
   Найденные_Символы="";

   Если ДлинаСтрокиНомера > 0 Тогда
       Для СК = 1 По ДлинаСтрокиНомера Цикл
           ТекСимвол = Сред(СтрТекстДок,СК,1);
           Если  СтрЧислоВхождений(СимволыКирилицы,ТекСимвол) > 0 Тогда
               Найденные_Символы=Найденные_Символы+ТекСимвол;
           КонецЕсли;
       КонецЦикла;
   КонецЕсли;

   Если Найденные_Символы<>"" Тогда
        #Если Клиент Тогда
           Предупреждение("В строке "+СокрЛП(СтрТекст)+" обнаружены недопустимые символы: """+Врег(Найденные_Символы)+"""");
        #КонецЕсли
   КонецЕсли;

   Возврат СтрТекст;

КонецФункции
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 01.08.2022
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому