1С 8.3 Проверка типа при работе с динамическим списком - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Проверка типа при работе с динамическим списком

Данные > Примеры кода 1С > 1С 8.3 Динамический список
Перейти в раздел примеры кода 1С 8.3:
//by telegram t.me/yellow_pad (Жёлтая тетрадь Блог программиста 1C)
При разработке команд в формах динамических списков нужно учитывать, что в выделенной строке списка могут быть не те данные, что ожидаются - пользователь может сгруппировать динамический список. Группировки рекомендуется пропускать, если вы их не обрабатываете специальным способом. Немного сокращенный пример кода из системы стандартов и методик разработки конфигураций:
Проверка типа при работе со списками в 1С 8.3:
&НаКлиенте
Процедура КомандаВФорме(Команда)

   Ожидаемый_тип = Тип("СправочникСсылка.МестаХранения"); // Например

   ВыделенныеСтроки = Элементы.Список.ВыделенныеСтроки;
   Для Каждого ОбъектИзВыделенныхСтрок Из ВыделенныеСтроки Цикл
       Если ТипЗнч(ОбъектИзВыделенныхСтрок) <> Ожидаемый_тип Тогда
           Продолжить;
       КонецЕсли;
       // Обработка объекта строки.
   КонецЦикла;

КонецПроцедуры
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 23.09.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому