1С 8.3 Выгрузка картинки в json - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Выгрузка картинки в json

Перейти в раздел примеры кода 1С 8.3:
Пример выгрузки картинки номенклатуры в json в 1С 8.3:
Процедура КнопкаВыполнитьНажатие(Кнопка)

   JSON = Новый ЗаписьJSON;
   JSON.ПроверятьСтруктуру = Ложь;
   ПараметрыЗаписиJSON = Новый ПараметрыЗаписиJSON( , Символы.Таб);
   JSON.ОткрытьФайл(ЭтаФорма.ПутьВыгрузки, КодировкаТекста.UTF8, , ПараметрыЗаписиJSON);

   JSON.ЗаписатьНачалоМассива();
   JSON.ЗаписатьНачалоОбъекта();
   JSON.ЗаписатьИмяСвойства("Номенклатура");
   JSON.ЗаписатьЗначение(СокрЛП(ЭтаФорма.Номенклатура.Наименование));
   //JSON.ЗаписатьКонецОбъекта();

   //JSON.ЗаписатьНачалоОбъекта();
   JSON.ЗаписатьИмяСвойства("Гуид");
   JSON.ЗаписатьЗначение(СокрЛП(ЭтаФорма.Номенклатура.УникальныйИдентификатор()));
   //JSON.ЗаписатьКонецОбъекта();

   КартинкаДв = ЭтаФорма.Номенклатура.ОсновноеИзображение.Хранилище.Получить();

   Если ТипЗнч(КартинкаДв) = Тип("Картинка") Тогда

       //JSON.ЗаписатьНачалоОбъекта();
       JSON.ЗаписатьИмяСвойства("ИмяКартинки");
       JSON.ЗаписатьЗначение(СокрЛП(ЭтаФорма.Номенклатура.ОсновноеИзображение.ИмяФайла));
       //JSON.ЗаписатьКонецОбъекта();
       //
       //JSON.ЗаписатьНачалоОбъекта();
       JSON.ЗаписатьИмяСвойства("ОсновноеИзображение");
       JSON.ЗаписатьЗначение(Base64Строка(КартинкаДв.ПолучитьДвоичныеДанные()));
       JSON.ЗаписатьКонецОбъекта();

   Иначе

       //JSON.ЗаписатьНачалоОбъекта();
       JSON.ЗаписатьИмяСвойства("ИмяКартинки");
       JSON.ЗаписатьЗначение("");
       //JSON.ЗаписатьКонецОбъекта();
       //
       //JSON.ЗаписатьНачалоОбъекта();
       JSON.ЗаписатьИмяСвойства("ОсновноеИзображение");
       JSON.ЗаписатьЗначение("");
       JSON.ЗаписатьКонецОбъекта();

   КонецЕсли;

   JSON.ЗаписатьКонецМассива();
   JSON.Закрыть();

КонецПроцедуры

Процедура ПутьВыгрузкиНачалоВыбора(Элемент, СтандартнаяОбработка)

   Режим                                     = РежимДиалогаВыбораФайла.Открытие;
   ДиалогОткрытияФайла                     = Новый ДиалогВыбораФайла(Режим);
   ДиалогОткрытияФайла.ПолноеИмяФайла         = "";
   Текст                                     = "ru = ""json-файл""; en = ""json-file""";
   Фильтр                                     = НСтр(Текст)+"(*.json)     |*.json";
   ДиалогОткрытияФайла.Фильтр                 = Фильтр;
   ДиалогОткрытияФайла.МножественныйВыбор     = Ложь;
   ДиалогОткрытияФайла.Заголовок             = "Выберите файл";

   Если ДиалогОткрытияФайла.Выбрать() Тогда
       МассивФайлов = ДиалогОткрытияФайла.ВыбранныеФайлы;
       ПутьВыгрузки     = МассивФайлов[0];

   Иначе
       Текст = "ru = ""Файл(ы) не выбран!""; en = ""File(s) not selected!""";
       Предупреждение(НСтр(Текст));
   КонецЕсли;

КонецПроцедуры
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 09.12.2022
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому