1С 8.3 Загрузка файла (скан подписи/печати для документов) в хранилище значения - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Загрузка файла (скан подписи/печати для документов) в хранилище значения

Данные > Примеры кода 1С > 1С 8.3 Хранилище значений
Перейти в раздел примеры кода 1С 8.3:
Загрузка файла в хранилище значения в 1С 8.3 (с 15 релиза) от сhеl1с:
&НаКлиенте
Процедура ЗагрузитьФайлСПодписью(Команда) // кнопка на форме

    ФильтрФорматов =
   "Все картинки (*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf)|"
    +"*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf|"
    + "Формат PNG (*.png)|*.png|"
    + "Формат JPEG (*.jpg;*.jpeg)|*.jpg;*.jpeg|"
    + "Формат GIF (*.gif)|*.gif|"
    + "Формат TIFF (*.tif)|*.tif|"
    + "Формат BMP (*.bmp;*.dib;*.rle)|*.bmp;*.dib;*.rle|"
    + "Формат ICON (*.ico)|*.ico|"
    + "Формат метафайл (*.wmf;*.emf)|*.wmf;*.emf|";

    ПараметрыДиалога = Новый ПараметрыДиалогаПомещенияФайлов("Выберите картинку с подписью", Ложь, ФильтрФорматов);

    ОписаниеОповещения = Новый ОписаниеОповещения("ПослеЗакрытияДиалогаВыбораПодписи", ЭтаФорма);
    // Описание оповещение будет вызвана после помещения файла во временное хранилище

    НачатьПомещениеФайлаНаСервер(ОписаниеОповещения,,,, ПараметрыДиалога, УникальныйИдентификатор); // c 8.3.15
    // Асинх.метод НачатьПомещениеФайлаНаСервер() возвращает результат и доп.параметры.
    // Результат - переменная (с типом ОписаниеФайла)
    // Доп.параметры - в примере пустые

КонецПроцедуры

 &НаКлиенте
Процедура ПослеЗакрытияДиалогаВыбораПодписи(ОписаниеФайла, ДопПараметры) Экспорт

    Если ОписаниеФайла.ПомещениеФайлаОтменено Тогда
        Возврат;
    КонецЕсли;

    АдресХранилища = ОписаниеФайла.Адрес; // АдресХранилища - реквизит формы

КонецПроцедуры

 &НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

    // Получаем файл из временного хранилища и кладём его в реквизит (с типом ХранилищеЗначения)
    Если ЭтоАдресВременногоХранилища(АдресХранилища) Тогда // АдресХранилища - реквизит формы
        ТекущийОбъект.Подпись = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(АдресХранилища));
    КонецЕсли;

КонецПроцедуры

Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 16.01.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому