1С 8.3 ЗаписатьЗначениеJSON - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 ЗаписатьЗначениеJSON

Перейти в раздел примеры кода 1С 8.3:
В версии 8.3.23 добавлены новые методы:
ЗаписатьЗначениеJSON(<Значение>) возвращает строку.
ПрочитатьЗначениеJSON(<Строка>) возвращает Структура, Массив, Число, Строка, Булево, Неопределено.
Старые методы ПрочитатьJSON и ЗаписатьJSON тоже можно продолжать использовать - они работают через объекты ЧтениеJSON и ЗаписьJSON соответственно.
Пример Записи JSON (с 8.3.23) НаКлиенте:
&НаКлиенте
Функция ЗаписьJSONНаКлиенте()

    СтрКлиент = Новый Структура;
    СтрКлиент.Вставить("КлиентИмя", "ОАО ""Савушкин продукт""");// ,  (произв. типа)
    СтрКлиент.Вставить("КлиентБелИмя", "ААТ ""Савушкін прадукт""");
    СтрКлиент.Вставить("УНП", "200030514");

    МассивМестХранения = Новый Массив;
    МассивМестХранения.Добавить("Минск");
    МассивМестХранения.Добавить("Брест");
    МассивМестХранения.Добавить("Барановичи");

    СтрКлиент.Вставить("Склады", МассивМестХранения);

    // Получение строки JSON (с версии 8.3.23)
    Возврат ЗаписатьЗначениеJSON(СтрКлиент);
    // Метод доступен:
    // тонкий клиент, веб-клиент, мобильный клиент, сервер, толстый клиент, внешнее соединение,
    // мобильное приложение (клиент), мобильное приложение (сервер), мобильный автономный сервер

КонецФункции
Устаревший пример Записи JSON (до 8.3.23) НаСервере:
&НаСервере
Функция ЗаписьJSONНаСервере()

    СтрКлиент = Новый Структура;
    СтрКлиент.Вставить("КлиентИмя", "ОАО ""Савушкин продукт""");
    СтрКлиент.Вставить("КлиентБелИмя", "ААТ ""Савушкін прадукт""");
    СтрКлиент.Вставить("УНП", "200030514");

    МассивМестХранения = Новый Массив;
    МассивМестХранения.Добавить("Минск");
    МассивМестХранения.Добавить("Брест");
    МассивМестХранения.Добавить("Барановичи");

    // Получение строки JSON (до версии 8.3.23)
    ЗначенияJSON = Новый ЗаписьJSON;
    ЗначенияJSON.УстановитьСтроку();
    ЗаписатьJSON(ЗначенияJSON, СтрКлиент);

    Возврат ЗначенияJSON.Закрыть();

КонецФункции
Пример экспортной функции (до 8.3.23):
Функция ДанныеВJSON(Значение, Знач ПараметрыЗаписиJSON = Неопределено, НастройкиСериализации = Неопределено) Экспорт

   Если ПараметрыЗаписиJSON = Неопределено Тогда
       ПараметрыЗаписиJSON = Новый ПараметрыЗаписиJSON(, Символы.Таб);
   КонецЕсли;

   ЗначенияJSON = Новый ЗаписьJSON();
   ЗначенияJSON.УстановитьСтроку(ПараметрыЗаписиJSON);
   ЗаписатьJSON(ЗначенияJSON, Значение, НастройкиСериализации);

   Возврат ЗначенияJSON.Закрыть();

КонецФункции
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 30.05.2022
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому