1С 8.3 Записать объект с установкой объектной блокировки - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Записать объект с установкой объектной блокировки

Данные > Примеры кода 1С > 1С 8.3 Документы
Перейти в раздел примеры кода 1С 8.3:
Как правильно записать объект в 1С 8.3:
// Параметры:
//  Объект                   - СправочникОбъект, ДокументОбъект.
//  РежимЗаписиДокумента     - РежимЗаписиДокумента
//  РежимПроведенияДокумента - РежимПроведенияДокумента
//
Процедура ЗаписатьОбъект(Объект, РежимЗаписиДокумента = Неопределено, РежимПроведенияДокумента = Неопределено) Экспорт

   // Ссылка = Документы.Анкета.НайтиПоНомеру("00001");
   // Объект = Ссылка.ПолучитьОбъект();

   Попытка
       //   Блокировка данных объекта для редактирования из кода
       //   https://its.1c.ru/db/v8std/content/490/hdoc
       Объект.Заблокировать();
       Если ЗначениеЗаполнено(РежимЗаписиДокумента) И ЗначениеЗаполнено(РежимПроведенияДокумента) Тогда
           Объект.Записать(РежимЗаписиДокумента, РежимПроведенияДокумента);
       ИначеЕсли ЗначениеЗаполнено(РежимЗаписиДокумента) Тогда
           Объект.Записать(РежимЗаписиДокумента);
       Иначе
           // Справочник, дополнительные параметры не требуются
           Объект.Записать();
       КонецЕсли;
   Исключение
       ЗаписьЖурналаРегистрации("Запись объекта", УровеньЖурналаРегистрации.Ошибка, Объект.Метеданные(),,ОписаниеОшибки());
   КонецПопытки;

   Если Объект.Заблокирован() Тогда
       Объект.Разблокировать();
   КонецЕсли;

КонецПроцедуры // ЗаписатьОбъект()
0
комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 12.07.2023
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому