1С 8.3 Заполнить элементы планировщика - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Заполнить элементы планировщика

Данные > Примеры кода 1С > 1С 8.3 Форма, элементы
Перейти в раздел примеры кода 1С 8.3:
На форме программно заполнить элементы планировщика в 1С 8.3:
Процедура ЗаполнитьНаФормеЭлементыПланировщика()

     // Инициализация элементов планировщика (записи по измерениям)
     ПланировщикЭлементы = Планировщик.Элементы;
     ПланировщикЭлементы.Очистить();

     Запрос = Новый Запрос;
     Запрос.Текст =
    "ВЫБРАТЬ
     |    Задача.Ссылка КАК Ссылка,
     |    Задача.Дата КАК Дата
     |ИЗ
     |    Документ.Задача КАК Задача";

     РезультатЗапроса = Запрос.Выполнить();
     Если Не РезультатЗапроса.Пустой() Тогда // Такая проверка рекомендуется фирмой 1С
         Результат = РезультатЗапроса.Выгрузить();
         Для Каждого Запись Из Результат Цикл

             ЭлементПланировщика = ПланировщикЭлементы.Добавить(Запись.Дата, Запись.Дата);
             ЭлементПланировщика.Текст = Запись.Ссылка;
             ЭлементПланировщика.Значение = Запись.Ссылка;
             ЭлементПланировщика.Картинка = БиблиотекаКартинок.Ресурс;
             ЭлементПланировщика.ЦветФона = WebЦвета.Бежевый;

         КонецЦикла;
     КонецЕсли;

 КонецПроцедуры

Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 02.04.2022
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому