1С 8.3 Проверка числа на целое - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Проверка числа на целое

Данные > Примеры кода 1С > 1С 8.3 Математика, числа
Перейти в раздел примеры кода 1С 8.3:
Узнать целое ли число? в 1С 8.3:
Функция ПроверкаЧислаНаЦелое(ВходящееЧисло) Экспорт

   Возврат ВходящееЧисло = Цел(ВходящееЧисло); //Возвращает Булево

КонецФункции

&НаКлиенте
Процедура ПроверкаСуммыНацелое() //Пример использования

   Для Каждого СтрокаТаблицы Из Объект.ТабличнаяЧасть Цикл

       Если ПроверкаЧислаНаЦелое(СтрокаТаблицы.Сумма) = Ложь Тогда
           Сообщить("Число не целое: " + СтрокаТаблицы.Сумма);
       Иначе
           Сообщить("Число целое: " + СтрокаТаблицы.Сумма);
       КонецЕсли;

   КонецЦикла

КонецПроцедуры
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 27.07.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому