1С 8.3 Проверка числа на чётность - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Проверка числа на чётность

Данные > Примеры кода 1С > 1С 8.3 Математика, числа
Перейти в раздел примеры кода 1С 8.3:
Узнать чётное ли число? в 1С 8.3:
Функция ПроверкаЧислаНаЧетность(ВходящееЧисло) Экспорт

   РезультатВычисления = ВходящееЧисло%2 = 0;
   Возврат РезультатВычисления; //Возвращает Булево

КонецФункции

&НаКлиенте
Процедура ЦиклПоСтрокамТАбличнойЧасти() //Пример использования

   Для Каждого СтрокаТаблицы Из Объект.ТабличнаяЧасть Цикл
       Если ПроверкаЧислаНаЧетность(СтрокаТаблицы.НомерСтроки) = Ложь Тогда
           Сообщить("Чётное число: " + СтрокаТаблицы.НомерСтроки);
       Иначе
           Сообщить("Не чётное число: " + СтрокаТаблицы.НомерСтроки);
       КонецЕсли;
   КонецЦикла

КонецПроцедуры
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 27.07.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому