1С 8.3 Вывести логотип в табличный документ - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Вывести логотип в табличный документ

Данные > Примеры кода 1С > 1С 8.3 Типовые (БП3, ЗУП, УТ)
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 Типовые
ФормированиеПечатныхФорм.ВывестиФаксимилеВТабличныйДокумент(Макет, ОбластьМакета, Организация, ) в 1С 8.3 УТ:
Процедура ВывестиЛоготипВТабличныйДокумент(Макет, ОбластьМакета, ИмяОбласти, Организация)Экспорт

   ФайлКартинки = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Организация, "ФайлЛоготип");

   Если Не ОбщегоНазначенияУТКлиентСервер.ЕстьРеквизитОбъекта(ОбластьМакета.Рисунки, "Логотип") Тогда
       // Картинки логотипа в этой области макета нет.
      Если Макет.Области.Найти(ИмяОбласти+"Логотип") <> Неопределено Тогда
           // Проверка картинки логотипа в области с логотипом
           ОбластьМакетаЛоготип = Макет.ПолучитьОбласть(ИмяОбласти+"Логотип");
           Если ОбщегоНазначенияУТКлиентСервер.ЕстьРеквизитОбъекта(ОбластьМакетаЛоготип.Рисунки, "Логотип")
               И ЗначениеЗаполнено(ФайлКартинки) Тогда
               ОбластьМакета = ОбластьМакетаЛоготип;
           Иначе
               Возврат;
           КонецЕсли;
       Иначе
           Возврат;
       КонецЕсли;
   КонецЕсли;

   Если Не ЗначениеЗаполнено(ФайлКартинки) Тогда
       ОбластьМакета.Рисунки.Удалить(ОбластьМакета.Рисунки.Логотип);
       Возврат;
   КонецЕсли;

   ДвоичныеДанныеФайла = РаботаСФайлами.ДвоичныеДанныеФайла(ФайлКартинки);

   Если ТипЗнч(ДвоичныеДанныеФайла) = Тип("Картинка") Тогда
       Картинка = ДвоичныеДанныеФайла;
   ИначеЕсли ТипЗнч(ДвоичныеДанныеФайла) = Тип("ДвоичныеДанные") Тогда
       Картинка = Новый Картинка(ДвоичныеДанныеФайла);
   Иначе
       Картинка = Новый Картинка;
   КонецЕсли;

   ОбластьМакета.Рисунки.Логотип.Картинка = Картинка;

КонецПроцедуры
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 06.04.2022
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому