1С 8.3 Вывод картинки на макет - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Вывод картинки на макет

Данные > Примеры кода 1С > 1С 8.3 Табличный документ / Макет
Вывести картинку PNG в Табличный документ в 1С 8.3:
Процедура ВывестиКартинкуВМакетПриПечати(ТаблДок, СтрокаМатериалы, ОбластьСтрокаТаблицы) // Экспорт

   // В свойствах ячейки Параметра ФотоМатериала - на вкладке Макет ПараметрКартинки указать ФотоМатериала
   // шрифт Параметра в ячейке делаем Белым, чтобы не было видно "Картинка"

   ФайлPNG = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(
   Справочники.Номенклатура.НайтиПоНаименованию(СтрокаМатериалы.Номенклатура), "ФайлPNG");

   Если ЗначениеЗаполнено(ФайлPNG.Наименование) Тогда

       ДвоичныеДанныеФайла                   = РаботаСФайлами.ДвоичныеДанныеФайла(ФайлPNG);
       Если ТипЗнч(ДвоичныеДанныеФайла)      = Тип("Картинка") Тогда
           КартинкаPNG                          = ДвоичныеДанныеФайла;
       ИначеЕсли ТипЗнч(ДвоичныеДанныеФайла) = Тип("ДвоичныеДанные") Тогда
           КартинкаPNG                          = Новый Картинка(ДвоичныеДанныеФайла);
       Иначе
           КартинкаPNG                          = Новый Картинка;
       КонецЕсли;
       ОбластьСтрокаТаблицы.Параметры.ФотоМатериала         = КартинкаPNG;

   КонецЕсли;
   ТаблДок.Вывести(ОбластьСтрокаТаблицы);

КонецПроцедуры
0
комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 21.12.2023
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому