1С 8.3 Вызов процедур или функций из модуля объекта в модуле формы - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Вызов процедур или функций из модуля объекта в модуле формы

Данные > Примеры кода 1С > 1С 8.3 Форма, элементы
Вызов процедур или функций из модуля объекта в модуле формы (&НаСервере) в 1С 8.3:
&НаСервере
Процедура Вызов_из_модуля_объекта()

   // сперва получаем объект:
   ДокОбъект = РеквизитФормыВЗначение("Объект");
   ДокОбъект.ПроцедураМодуляОбъектаЭкспортная();
   //...

   // примечание:
   // если у разных объектов, например: два документа и надо в форму одного документа вызвать процедуру из другого документа,
   // то в этом случаи надо процедуру помещать в модуль менеджера и вызывать ее как Документы.НазваниеДокумента.НазваниеПроцедуры
   // соответственно все вызовы на сервере

КонецПроцедуры
Пример №1: Вызов процедур из модуля объекта внешней обработки в модуле формы в 1С 8.3:
// модуль формы:
&НаКлиенте
Процедура Прочитать(Команда)
   Вызов_из_модуля_объекта_внеш_обработки();
КонецПроцедуры

&НаСервере
Процедура Вызов_из_модуля_объекта_внеш_обработки()
   РеквизитФормыВЗначение("Объект").ЗаполнитьТЧ();
КонецПроцедуры

// модуль объекта внешней обработки:
Процедура ЗаполнитьТЧ() Экспорт
   // Ваш код
КонецПроцедуры
Пример №2: Вызов процедуры из модуля объекта внешней обработки в модуле формы в 1С 8.3:
// Вариант реализации для внешней обработки:
// 1. Создать реквизит обработки "Модуль"
// 2. В модуле объекта определить экспортную процедуру "Процедура ИмяПроцедуры Экспорт ..."
// 3. В теле модуля объекта выполнить присваивание: "Модуль = Объект;"
// 4. В модуле формы вызвать "Объект.Модуль.ИмяПроцедуры();"
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 17.08.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому