1С 8.3 БСП ТаблицаЗначенийВМассив - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 БСП ТаблицаЗначенийВМассив

Данные > Примеры кода 1С > 1С 8.3 БСП > Данные
Перейти в раздел примеры кода 1С 8.3:
1С 8.3 БСП ТаблицаЗначенийВМассив. Преобразует таблицу значений в массив структур. Может использоваться для передачи на клиент данных в том случае, если таблица значений содержит только такие значения, которые могут быть переданы с сервера на клиент.

p.s. - если в конфигурацию не встроена БСП, можно использовать авторские методы:
Примера кода от rayastar
Результат = ОбщегоНазначения.ТаблицаЗначенийВМассив(ТаблицаЗначений);
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Функция
Функция ТаблицаЗначенийВМассив(ТаблицаЗначений) Экспорт

   Массив = Новый Массив();
   СтруктураСтрокой = "";
   НужнаЗапятая = Ложь;
   Для Каждого Колонка Из ТаблицаЗначений.Колонки Цикл
       Если НужнаЗапятая Тогда
           СтруктураСтрокой = СтруктураСтрокой + ",";
       КонецЕсли;
       СтруктураСтрокой = СтруктураСтрокой + Колонка.Имя;
       НужнаЗапятая = Истина;
   КонецЦикла;
   Для Каждого Строка Из ТаблицаЗначений Цикл
       НоваяСтрока = Новый Структура(СтруктураСтрокой);
       ЗаполнитьЗначенияСвойств(НоваяСтрока, Строка);
       Массив.Добавить(НоваяСтрока);
   КонецЦикла;
   Возврат Массив;

КонецФункции
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 11.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому