1С 8.3 Преобразование Массива В Таблицу Значений - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Преобразование Массива В Таблицу Значений

Данные > Примеры кода 1С > 1С 8.3 Массив
При наличии в конфигурации БСП, можно использовать метод ТаблицаЗначенийВМассив.
Преобразование массива в ТЗ в 1С 8.3:
&НаСервереБезКонтекста
Функция ПреобразованиеМассивВТаблицуЗначений(Массив)

   ТЗ = Новый ТаблицаЗначений;

   Для Каждого СтрокаМассива Из Массив Цикл

       Если ТЗ.Колонки.Количество() = 0 Тогда
           Для Каждого ЭлементМассива Из СтрокаМассива Цикл
               ТЗ.Колонки.Добавить(ЭлементМассива.Ключ);
           КонецЦикла;
       КонецЕсли;

       НоваяСтрока = ТЗ.Добавить();
       Для Каждого ЭлементМассива Из СтрокаМассива Цикл
           НоваяСтрока[ЭлементМассива.Ключ] = ЭлементМассива.Значение;
       КонецЦикла;
   КонецЦикла;

   Возврат ТЗ;

КонецФункции
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 29.03.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому