1С 8.3 Преобразование Таблицы Значений в Массив - Программист 1С Минск. Автоматизация бизнеса.

Популярные страницы:
Перейти к контенту

1С 8.3 Преобразование Таблицы Значений в Массив

Данные > Примеры кода 1С > 1С 8.3 Массив
При наличии в конфигурации БСП, можно использовать метод ТаблицаЗначенийВМассив.
Преобразование ТЗ в массив в 1С 8.3:
// Функция преобразует ТаблицуЗначений в Массив из структур.
//
&НаСервереБезКонтекста
Функция ПреобразованиеТаблицыЗначенийВМассив(ТЗ)

   Массив = Новый Массив;

   // Запишем в массив
   Для Каждого Строка Из ТЗ Цикл

       СтрТЗ = Новый Структура;
       Для Каждого ИмяКолонки Из ТЗ.Колонки Цикл
           СтрТЗ.Вставить(ИмяКолонки.Имя, Строка[ИмяКолонки.Имя]);
       КонецЦикла;

       Массив.Добавить(СтрТЗ);

   КонецЦикла;

   Возврат Массив;

КонецФункции
Поиск кода
0
Комментарии
____________________
Copyright©, «Программист 1С в г.Минске», 29.03.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому